My Community Dashboard

  • Hi Dave, Nick,

    First of all thanks foyr quick response.

    Let me start by saying i fixed it, but i had to take another route then Dave suggested.

    I already read about the

    chroot /mnt/sysimage
    cd /
    cp -a /boot/efi/EFI/centos/* /boot/efi/EFI/clearos/

    part, but i couldn't do a chroot /mnt/sysimage. Something about not able to do or not able to find (not sure eactly what it said).

    So i decided to try copy it on a different way. I booted not from the Clearos rescue anymore but from one of my other rescue USB devices (yay, lucky me, that i recently created and updated one). From ther i tried several different tools, but in the end with pmagic i could mount the sysimage amongs other partitions. Then i did copy the grubx64.efi file from Centos folder to Clearos.

    After that a reboot presented me with the latest and some previos kernels.

    First i Choose the newest, but at a certain point it took me to a rescue prompt (not seen that one before), so i decied to boot into the previous kernel.

    Then i could boot my Clearos server fine again, i just thought lat's give it another go and run the update to the latest kernel again.

    No problems after that anymore and also Samba was working fine again!


    Normally only default (none test) repo's are the ones i am using, but when i saw in my console the update for Samba and i tried to update, my system complained about missing depenedencies, regarding libtevent and libldb.

    so installed only those two with:

    yum --disablerepo="*" --enablerepo="centos-unverified" install libtevent and yum --disablerepo="*" --enablerepo="centos-unverified" install libldb

    After that the samba update ran without a problem with the default repo's.

    My grub version at this point is: grub2-2.02.1-0.76.v7.1.x86_64