Profile Details

Toggle Sidebar
Recent updates
  • Tyler Davis
    Tyler Davis replied to a discussion, Teamspeak 3 Server Question

    Nick Howitt wrote:

    So who is user 1000? Are you using "useradd" to add your tsdaemon user? If so you must use the -r switch to create it as a system user. If you don't, it will end up in the space controlled by LDAP and get wiped on every reboot.

    That's a good question, and one I had too, I'm not sure who user 1000 is, it's definitely not one I had created, I assumed it was some sort of system account. That's a bit concerning.

    When I created the account I did not use the -r switch. I did get this issue working last night though by using the -R switch on my chown command. Using that I was able to go in and start the server with that script, and pull tsdaemon out of the sudoers file. However, and this may play into what you're saying with the system user, I attempted to reboot the server this morning, and when it came back up it doesn't look like the cron job worked. I was still able to use su tsdaemon, and get to my home directory to manually launch the script/server again, but the cron job didn't pick it up. Would that be caused by not having used that -r switch?

  • Tyler Davis
    Tyler Davis replied to a discussion, Teamspeak 3 Server Question

    Ah, not sure how I forgot this part, I suppose the most important part, here's the error I get when attempting to run the start script:

  • Tyler Davis
    Tyler Davis started a new discussion, Teamspeak 3 Server Question

    Teamspeak 3 Server Question


    I recently installed 7.2, and I'm getting it all set back up to my previous setup. I'm currently trying to setup a teamspeak 3 server. Previously I had done this as root, and just had it running as root every time the box would reboot, or go down. Now, in the name of security, I've decided to try and set it up as it's own little daemon user, but I'm running into issues. I started by creating the user "tsdaemon", adding the password, then downloading the server file for linux for the website into the "/home/tsdaemon" directory. Once it was down I attempted to tar xvfj the file (it was a bz2 zip), doing that returned an error that said no permission allowed. So I backed out and added the daemon account to my sudoers file, just to get the setup done. Tried again, and I didn't have bzip installed, so I installed bzip, and got my package unzipped.

    Next I went into the freshly unzipped folder and tried to run the start script, again issues with permission denied, so I ran it as sudo, success. So I tried backing out again, and changing the owner of the directory to my tsdaemon user (chown tsdaemon /home/tsdaemon/teamspeak_directory_here). Switched back to my daemon user and attempted the start script again, still no luck. Ultimately I want to get this setup to start on reboot automatically by adding a cronjob, but if it can't start by manually running the start script, I don't have a ton of faith in that cronjob working.

    What do I need to do to give my daemon user the proper permissions to successfully run that start script? My cron job is just going to be:

    I'm not yet super well versed in linux permissions systems, but here's the output of my ls -al on the folder:

    Anyone have any suggestions?

  • Marcel van Leeuwen wrote:

    One thing that crossed my mind is that maybe there are some corrupt files on a mirror when you did you first install. Now with your second install you pulled in from a different mirror solving the problem but I'm just a guessing...

    I had actually thought about that too, so just for fun, I just used the same install media (same USB drive, didn't recreate it), as the first time, for my second install. So that blew that theory up, I honestly have no idea what changed!

  • Just finished a full reinstall, seems to be working now. Frustrating that I couldn't figure it out, but I'm glad it's working!

  • Marcel van Leeuwen wrote:

    Maybe a stupid suggestion but what I do in such situations is reboot my server. Sometime it solves the problem... mostly not...

    It indeed sounds like your marketplace app is corrupt or something.

    No worries, I'll take any suggestions!

    Unfortunately I have tried that a few times, and in this situation, no such luck.

  • Additionally, if I click the question mark to view more about the app, and hit the "Download and Install" button there, it does nothing, like it's not actually a link to install anything.

  • Ben Chambers wrote:'re digging up an old post. Your repos look fine.

    What about:


    I am! Sorry about that :( I had been putting off upgrading my 6.6 install for so long just because I didn't want to play with it. But today I was trying to get some scripts working for some plex monitoring tools that required Python 2.7, and I was having trouble getting that up and running, so I figured today might as well be the day to make the jump!

    yum upgrade is running right now, doing a lot of work, that may be the solution! We'll see in a bit.

    As far as what I was trying to install, pretty much anything, there's a long list but as an example, the Administrators app is one.

    Another weird thing I'm noticing, on my 6.6 install I had installed google-authenticator, and gotten that setup to require a OTP on SSH logins, on 6.6 I was able to just do:

    On 7.2 though, it's coming back that that is not a package, did some of the repos from 6.6 get axed in the 7.2 release? Or could that be another symptom of the issue I'm having?

  • Hello, hopefully someone is still around that has an answer to this. I'm having this exact issue as well, just freshly installed ClearOS 7.2, coming off of 6.6, I verified my clearos-updates are enabled, and even ran that line just to be sure. I can go through the marketplace and mark up a bunch of apps to install, then hit Install Selected Apps, and it will just drop and say that no apps were selected to install. Very frustrating!

    Anyone have a fix for this? My output from yum repolist is:

  • Tyler Davis
    Tyler Davis started a new discussion, SSH Google 2FA Problems

    SSH Google 2FA Problems


    First off, sorry if this is the wrong section, I couldn't find one super applicable to this question...BUT:

    I'm working on setting up Google Authenticator 2FA for all SSH logins on my server, I started following a forum post here, but it seems like they've really simplified the process so I ended up following another, more generic CentOS post here. So far I've done the following:

    Installed google-authenticator.

    Setup the the app on my phone, and initiated google-authenticator.

    Modified /etc/pam.d/sshd with the line:

    Modified /etc/ssh/sshd_config to show:

    Restarted the sshd service.

    After that I completely exited ssh, and reconnected to it, trying both my root, and user account. Neither seems to have been impacted by anything I changed, at all. It simply has me login as normal. Does anyone have experience with this? Have you guys tried adding 2FA to your systems lately? Any help is much appreciated!