Profile Details

Toggle Sidebar
Recent updates
  • You may be using the wrong URL.

    Sorry, typo in my post, not in what I entered in Terminal. Checked again, and I did use the //.

    Can you ping "plexserver". Does it resolve to

    Yes, and Yes.

    PING ( 56 data bytes
    64 bytes from icmp_seq=0 ttl=64 time=0.676 ms
    64 bytes from icmp_seq=1 ttl=64 time=0.652 ms
    64 bytes from icmp_seq=2 ttl=64 time=0.454 ms
    64 bytes from icmp_seq=3 ttl=64 time=0.702 ms
    64 bytes from icmp_seq=4 ttl=64 time=0.603 ms
    --- ping statistics ---
    5 packets transmitted, 5 packets received, 0.0% packet loss

    Is ClearOS in Standalone or Gateway mode? Is it doing DNS/DHCP?

    Standalone, no firewall. It is not doing DNS. It WAS doing a (duplicate) DHCP server by mistake, but I changed DHCP to Disabled, restarted router (which is the DHCP server), ClearOS and my iMac.

    It makes no difference.

    FWIW is not a brilliant choice of subnets.

    As it is the router's default, I just used it.

    What's the drawback?

    It would be a bit of a pain to change it, as I have about 30 permanently active devices on the network, and another 20 that were or can be active occasionally.

    Most have reserved fixed addresses handed out by the router.

  • Can't connect to samba server over network

    I posted some months ago about this problem, but didn't get a resolution, and the Covid-19 lockdown distracted my attention until now. Here's a link to the previous topic:

    I still can't get a samba connection to my ClearOS server, which is set up to host a Plex Media Server. I've had a series of different problems connecting to the plex server to access and play my media, only just resolved.

    So I'm coming back to the issue - how do I get Samba to work?

    The last comment in the previous thread asked if I had set up Flexshares. The answer is 'I have' and there is one set up called <blockquote>plexmedia</blockquote>. In the ClearOS console accessed at, it shows

    And the Samba configuration panel says:

    Using ssh from the iMac Terminal, I can connect and browse the files on the ClearOS server using Midnight Commander, so on request I can look at the contents of (for example) files.

    I've checked that the samba service is running:

    When I try to access the files in <blockquote>plexmedia</blockquote> from Finder on my iMac, whether by <blockquote>ip</blockquote> address or <blockquote>//plexmediaserver/plexmedia</blockquote>, I just just get a timeout with error message.

    Whey I try to access the server from Terminal using

    I just get an error message: "no such file or directory."

    I get the same result when trying to access the server from my Mac laptop instead of my iMac.

    It's really annoying that I HAVE had this working in the past, on a previous standalone ClearOS server, whereas this one is a virtual machine running under VMware ESXi 6.5.

    Any suggestions to diagnose and fix this problem will be very much welcome. I'm stuck.

    I CAN upload files via FTP, but it isn't nearly so convenient, or as fast, so I'd really like to get SAMBA working if possible.

  • Using Finder, you just give the hostname or IP address. IF it connects, you may at first access be prompted for username and password. But I'm not getting that far. It's not seeing the ClearOS machine as a samba share resource at all. As in window, if there isn't anything shared, you can't connect, but the plexmedia folder is shared on the server, and the Plex client can now see it and work with it.

    Just that Finder can't find it, to allow easy upload of any new media files.

    As an aside, is there any way I can set this forum to remember to sort my posts with oldest first? Otherwise, it's hard to find and read the posts in sequence. With Latest first, the original post is on the top, but the rest are in reverse order of posting.

  • Nick Howitt wrote:

    You have a typo somewhere, either in your configs or you error message. The finder error mentions, but this is not a private address. the earlier line mentions

    If you are using ClearOS for DNS, you'd do better to use the CleearOS DNS Server to map plexserver to your ClearOS IP.

    It was a typo in my manual transcription of the error message (the message wouldn't copy/paste).

    I typed it correctly in the Go/Connect to server address box. The problem isn't that plexserver doesn't map to the IP address, but that I can't connect even to the IP address itself.

  • Nick said: "Does "plexserver" resolve to Try pinging it."

    Using Terminal in Mac, no it doesn't resolve but says "unknown host".

    Pinging the IP address does get a response:

    I can add an entry to the hosts file on my iMac to get a resolution of 'plexserver'.

    But I still can't get smb access to the replacement server. Even using the IP address, Finder won't connect via and eventually returns a pop up message box saying . I am the system administrator, and have no idea how to fix this.

    I've looked at the file and couldn't see anything amiss, and also in .

    I changed 'browseable = No' to 'browseable = Yes' in a couple of places and restarted the smb service but it hasn't made any difference. There were no error messages after restarting smb and nmb servers.

    One error message after the start, which I don't understand and can't see how to fix, when I run :

    "Can't open username map /etc/samba/smbusers. Error No such file or directory"

    What does that mean, and does it matter?

    It isn't desperately important, but it is helpful to have smb access to upload new media files. I can do it via FTP, but it isn't so convenient.

    Where else might I look?

  • I finally managed to figure out how to get an SSH connection to the ClearOS 'plexserver', and ran the command you suggested.

    winbind seems to be working:

    The Flexshare is where you said it would be - in and my media content is within that folder, to which I'd copied it via FTP.

    The Samba configuration says the share should be at

    And the Plex Media Server is installed, and set up by default to allow access to media by any device on the network.

    So everything so far seems to be set up.

    But I still can't figure out what to do to get access to the media.

    If I try in a browser , which is the usual way to access the server, I get "Connection refused".

    Then, a small brainwave: try without https://, just http://

    And BINGO - I have a connection, prompting me to log in to my Plex account.

    So thank you everyone who's helped me get to this point.

  • Sorry my posts have got out of order, and I haven't responded to your request to run 'systemctl status winbind' in a terminal.

    I can't seem to get a VM console any more. All I get is this set of unhelpful choices instead.

  • I've drafted a reply to this three times, and lost it three times inadvertently, without any draft being saved. Must get used to this forum.

    I've added a Flexshare off the filesystem root, at //plexserver/plexmedia.

    I can connect to it via FTP, and the Samba settings page says I can access it at the same URL.

    But i can't access it from Finder, either using Finder/Go/Connect to Server //plexserver/plexmedia or to its IP address smb://

    So I'm still missing a crucial connection to Plex - I can't connect via the Plex client either.

    Again, I'm missing something, but can't see what and would be grateful for further help.

  • I've successfully installed a flexshare now, and can FTP to it from my local network at

    And i've set up a samba server and created a share at //plexserver/plexmedia, but can't access it from another computer on the same network. either at the name //plexserver/plexmedia (which shows up as a lessong, or via the IP address which is smb//:

    Also, at the moment I can't seem to get a terminal window in which to try your information gathering instruction.

  • Many thanks for such a prompt response, Nick. I'd forgotten about the need to have a Flexshare first, as it's now at least five years since I last used ClearOS.

    I'll follow that up later this evening, or on Wednesday.