Profile Details

Toggle Sidebar
Recent updates
  • Roundcube App not installing from Marketplace [Solved]

    Thanks Ben!

    The app is up and running although the integration seems a little rough-edged at this stage. Users (fullname and email address) are not transposed into it so I had to do that manually. Not a problem whilst testing but I couldn't locate a config file in /etc so I am unable to provide additional info.


  • RoundCube app not installing from Marketplace

    Hi Ben
    Unfortunately your instructions only partially worked!
    Still missing Dependencies :
    --> Finished Dependency Resolution
    Error: Package: roundcubemail-1.1.3-1.v7.noarch (clearos-contribs-testing)
    Requires: php-pear-Mail-Mime
    Error: Package: roundcubemail-1.1.3-1.v7.noarch (clearos-contribs-testing)
    Requires: php-pear-Net-IDNA2
    Error: Package: roundcubemail-1.1.3-1.v7.noarch (clearos-contribs-testing)
    Requires: php-pear-Mail-mimeDecode
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    Still waiting patiently for a solution

  • RoundCube app not installing from Marketplace
    Failed with error: "Exception: [u'ERROR with transaction check vs depsolve:', 'roundcubemail >= 1.1.1 is needed by app-roundcubemail-core-1:2.0.0-1.v7.noarch']"
    Any chance of fixing that soon?

  • CarlMcD
    CarlMcD replied to a discussion, eMail-Problems after Update

    Hi Ben

    Thank you!
    Problem resolved :D


  • CarlMcD
    CarlMcD updated their profile
  • CarlMcD
    CarlMcD replied to a discussion, eMail-Problems after Update

    Probably not the correct place for this but am also now experiencing the same problem after my system updated from (7.1 beta 3) to (7.1 RC1) with the following message:

    <>: Command died with status 255: "/usr/sbin/mailprefilter".
    Command output: PHP Fatal error: Call to undefined method Net_SMTP::_put()
    in /usr/clearos/apps/mail_routing/libraries/Transport.php on line 98

    Transport.php on line 98 equates to: $this->transport->_put('DATA');

    Any reason why this should have happened? Only default clear-repo and odoo-repo enabled.

    Here is the output of postconf –n:

    [root@server ~]# postconf -n
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    bounce_queue_lifetime = 6h
    broken_sasl_auth_clients = yes
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    content_filter = mailprefilter
    daemon_directory = /usr/libexec/postfix
    data_directory = /var/lib/postfix
    debug_peer_level = 2
    debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5
    header_checks = regexp:/etc/postfix/header_checks
    html_directory = no
    inet_interfaces = all
    inet_protocols = ipv4
    local_recipient_maps = $alias_maps $virtual_alias_maps
    luser_relay =
    mail_owner = postfix
    mailbox_size_limit = 102400000
    mailbox_transport = mailpostfilter
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    message_size_limit = 102400000
    message_strip_characters = \0
    mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,
    mydomain =
    myhostname =
    mynetworks = [::1]/128, [::1]/128
    myorigin = $mydomain
    newaliases_path = /usr/bin/newaliases.postfix
    queue_directory = /var/spool/postfix
    recipient_delimiter = +
    relayhost =
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, check_policy_service unix:/var/spool/postfix/postgrey/socket
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain = $mydomain
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_cert_file = /etc/postfix/cert.pem
    smtpd_tls_key_file = /etc/postfix/key.pem
    smtpd_tls_loglevel = 1
    smtpd_use_tls = yes
    transport_maps = hash:/etc/postfix/transport
    unknown_local_recipient_reject_code = 550
    virtual_alias_maps = $alias_maps, $virtual_maps, ldap:/etc/postfix/, ldap:/etc/postfix/

    *I noticed that "php-pear-Net-SMTP-1.7.1-1.el7" was an update just prior to the main system upgrade and that's the only changes there has been recently.