0 votes
Hello all,
I've a Windows Controller (AD) under Windows 2003. My idea was to build a new ClearOS server, installing Samba Directory and connect my COS server as a domain controller. Then replicate the AD and finally stop my old Windows controller.
Installation of samba and connecting it to my AD as a new domain controller was a success. The, the replication seems to worked but I can't go further. My samba service can start but with the following errors :

/usr/sbin/samba_dnsupdate: tkey query failed: GSSAPI error: Major = Unspecified GSS failure. Minor code may provide more information, Minor = Server not found in Kerberos database.
../source4/dsdb/dns/dns_update.c:295: Failed DNS update - NT_STATUS_UNSUCCESSFUL

I did not install a BIND dns server and I was wondering if this could be the reason ...

Trying to have a look on the replication gives me the following error : (srv-cos is my new ClearOS server)

[root@srv-cos ~]# samba-tool drs showrepl
ERROR(<class 'samba.drs_utils.drsException'>;): DRS connection to srv-cos.mwp.local failed - drsException: DRS connection to srv-cos.mwp.local failed: (-1073741772, 'The object name is not found.')

thanks to all for your help :)
Tuesday, March 14 2017, 03:09 PM
Share this post:
Responses (1)
  • Accepted Answer

    Wednesday, March 15 2017, 06:18 AM - #Permalink
    0 votes
    Hello all,
    So finally I solved the problem. After having made my changes in samba.conf, I had to edit my resolv.conf and resolv-peerdns.conf.
    Now both machines a replicating (Windows 2003 Server and ClearOS 7.3).
    But I read on another post that I can't use that for the while because flexshares and users management are not working with Samba directory :( Can someone confirm that ? For the while, If i go to my users or groups menu, I get the following error : Ooops! Invalid credentials

    Thanks :)
    The reply is currently minimized Show
Your Reply