Profile Details

Toggle Sidebar
Recent updates
  • Gordon Howell
    Gordon Howell replied to a discussion, IMAP broken

    Alex, I read your message, sorry for not replying. I've solved this issue by leaving ClearOS, replacing my networking equipment with Unifi and moving my domain to iCloud under their custom domain solution. Thanks for your suggestion. I can't seem to find the link to PM's or I'd reply there. I'll mark this post "solved" if I can figure out how to do that. There seems to be a number of things missing that make this board harder to use.

  • Gordon Howell
    Gordon Howell updated their profile
  • Gordon Howell
    Gordon Howell replied to a discussion, IMAP failure

    A restore from system backup fixed the problem. Still don't know what caused it.

  • Gordon Howell
    Gordon Howell started a new discussion, IMAP failure

    IMAP failure

    ClearOS release 7.9.1 (Final) running, imap server is running, according to the GUI. However, the last connection from Apple Mail was yesterday afternoon around 5 p.m. and I cannot connect to IMAP this afternoon at all. From the event log, I see the Cyrus user logging in and out, so it appears all is running on the ClearOS server, yet, none of my clients will connect. I tried a password change, no luck. Tried setting up a POP account and get the "can't verify user or password" error. I've done everything my Linux challenged abilities knows to do other than uninstalling and reinstalling the IMAP server. Also checked the firewall, and ports 143 and 993 are both open. In Apple's connection doctor window, I can see the mail client attempting to connect via both ports with no success. Very frustrating, any suggestions appreciated.

  • Figured it out. Apparently the dowloaded files from Embarcadero to complete the installation, those that set up Windows, MacOS and IOS programming, are encrypted. I had ClearOS Antimalware set up to block encrypted files. Turned that off, and the last file I needed downloaded without error.

    Would have been sorta nice if the installer had a reasonable message about why things were failing.

    This thread can be closed

  • Delphi installation fails through ClearOS

    I've been trying to install Delphi's Community Edition for the last several days. The basic program installs, however, when trying to use their GetIt repository installer, the install kept failing, indicating a corrupted download. Embarcadero doesn't support any help for that edition, and posts in a public forum produced no workable solutions. I finally decided, as I had gotten a proxy server notification from ClearOS when trying to get something to work, that I would use a hot spot and bypass ClearOS. Magically, everything began to work, and all the packages installed.

    So it appears that something is blocking the downloads. I have no information on a particular port that may be blocked, but I suspect that may be the case. Is there a way or a report that would indicate a block of incoming data?



  • Interesting suggestion Nick. But I think I have found an easier one, albeit one that requires a hardware change and different service here.

    I talked to Comcast Business this morning and can get a static IP, 600 Mb service (not guaranteed of course) and access to port 25 if needed. My SMTP2GO contact noted that my current Comcast dynamic IP address is blacklisted with two major services, due to ComCast's block assignment, and I can't get that lifted. He speculates that the blacklist was what might be causing ComCast, who provides the IP, to disallow a connect. Seem logical, although it does bring the chicken or the egg, or perhaps Catch 22 into the equation.

    Anyway, the ComCast gentleman is investigating whether getting emails to a static address with them will be an issue. If I move to that service, drop Lumos altogether, the net cost is almost the same, so I expect, once the mail situation is confirmed, that I will do just that. Their business max service also provides an LTE 4G automatic backup with two different cell providers, so the need for the Lumos DSL backup goes away as well.

    There will be some work involved in removing all references to the email address, but I know most, if not all of the location that I have used it either as a logon or a return email address, so once all that is changed over, I can dump Lumos without much regret. It's not the same service I moved to from Verizon more than 20 years ago.

    I do appreciate the time you've spent in trying to help me with this problem. If nothing else, I've learned a great deal and expect that this solution is going to work, and stop the outages altogether.


  • Once Lumos comes back, I will be able to retrieve that mass of emails stuck at ClearOS. But that being said, I am now married to them if I want to continue running my own email server. Comcast is the only game in town with any speed. Verizon will never bring FIOS here, neither will Segra, and according to Comcast, most of the major providers block port 25. There's got to be some solution for this, but my tiny brain is tired and I am quitting for the day. Thank you Nick.

  • The more we talk about this, the more confused I become.

    I used tcpdump on ports 25, 465 and 587 to monitor an outbound email to my ntelos/lumos address. The send went out through port 587, not 465 or 25, on my system. So the changes I made to postfix's file have routed emails to my outbound smtp provider, which is smtp2go, via that port. They are being received at smtp2go without issue. Yes, it is an outbound server that I have used for a number of years when I could not get SMTP to function on ntelos/lumos.

    However, when I look at the emails directed to my domain name,, smtp2go indicates that it is trying to route them to the correct domain address resolved by dns but the connection to my domain times out. Since you are saying that all incoming emails are routed through port 25 and comcast blocks port 25, therein lies the problem.

    I can only assume that ntelos/lumos does NOT block port 25, but since that service is still out for me, I can't confirm it until it returns. So the problem remains -- if the comcast connection times out, routing email to the backup at ClearOS, and that backup restores via port 25, how do I deal with this problem.

    I apologize for being somewhat dense, but it just doesn't make sense. Sorry to waste so much of your time and draw on your good nature.

  • Nick, ComCast blocks port 25. That is probably what you are seeing. The question is how do I route mail delivery to my iMap server through 465 or 587. Port 25 is open on my firewall, but your telnet to port 25 should never get through ComCast, and I am sure that is what you are seeing. I need to query SMTP2GO to see how they are routing, I guess. If those emails are being routed to port 25, that's probably the answer to this problem.