Profile Details

Toggle Sidebar
Recent updates
  • I used the latest *.iso (Community Edition), thought the version was 7.2 but must be 7.9. Can't check it as my webconfig still is the very basic original one because of the certificate issue.

  • Certificate issue after new installation

    I did a new installation of ClearOS 7.2. The installation process and registration went fine. After a few hours "ping" showed the correct URL. Nevertheless I cannot use Marketplace or other repos, reporting

    I tried

    and got back

    That seems pretty old to me. Problem could be that for registration I used a site name I had used in the past. But changing the registration seems impossible.

  • Thanks again. I will rebuild my server and stick to webconfig as much as possible, certainly for using Samba. Hopefully this problem doesn't come back.

  • Thank you, Nick. Where would we be without you? I only blame myself, but I am not really aware what went wrong. Next to the webconfig I use webmin for things webconfig doesn't handle well like LVM, RAID or iSCSI configs and of course the file manager. Sometimes, while working in webmin, I would get a notification of new sofware which I normally blindly accept. That's probably the cause and, yes, I have probably also used webmin for making Samba changes. While I will not blame anybody besides myself I find it peculiar that this problem can still arise so easily and it is so difficult to deal with. Rebuilding my very simple server wouldn't be difficult. I am just a bit embarrassed this would still be necessary as this seems to have been a common problem for years. But your help is greatly appreciated!

  • Roel  van der Heide

    Another Samba / slapd problem

    I have a few ClearOS systems, all running ClearOS7, latest update. One system (SAN2) is just a basic back-up system for the entire network. It networks happily with all othe systems using rsync, filezilla, etc. It used to work with Windows systems in the network, as I set it up without an Account Manager system, just a basic filesharing system. Suddenly, my SAN2 system has an Account Manager, and it is offline. I assume it was entered into the system via yum update, as I cannot remember having done that myself. Obviously I cannot use Samba now.
    I have seen the different posts on this forum, so I know it will not be easy to remove slapd. I can rebuild the system from scratch which would be a bit of an embarrasment. Before doing that and before I spend too much time on this common issue, I would be interested to know whether there currently is an easy fix so that I can re-use Samba for simple filesharing. Status of slapd:

  • That makes sense.
    I now need to recollect some special installation requirements for non-ClearOS apps that I have and then I will rebuild my system.
    But first remove app-samba. The slow disk-IO turned out to be a harddisk flaw though, so nothing related to winbind.
    Thanks again.

  • Thank you very much Nick, for the excellent explanations and for all the work you're doing for all of us.
    Trying to be helpful, here are my 2 cents:

    yum reinstall app-samba
    systemctl restart winbind.service
    journalctl -xe
    .. systemd[1]: Unit winbind.service entered failed state.
    .. systemd[1]: winbind.service failed.
    .. servicewatch[22102]: restarting winbind
    .. polkitd[919]: Registered Authentication Agent for unix-process:24734:8819234 (system bus name :1.18811 [/usr/bin/pkttyagent --notify-fd 5 --fallback],
    .. systemd[1]: winbind.service: main process exited, code=exited, status=1/FAILURE
    .. systemd[1]: Failed to start Samba Winbind Daemon.
    -- Subject: Unit winbind.service has failed
    -- Defined-By: systemd
    -- Support:
    -- Unit winbind.service has failed.
    -- The result is failed.
    .. systemd[1]: Unit winbind.service entered failed state.
    .. systemd[1]: winbind.service failed.
    .. polkitd[919]: Unregistered Authentication Agent for unix-process:24734:8819234 (system bus name :1.18811, object path /org/freedesktop/PolicyKit1/Authe

    Hope this helps

  • Winbind automatically restarting every 5 mins

    Today I noticed a sudden slowness of disk-IO on my ClearOS7 server. Looking at the logs there has been a constant repetition of 2 commands every (exactly) 5 mins for the last 8 hours and counting :
    servicewatch: sanity checking winbind , followed by
    servicewatch: restarting winbind after 30 secs.
    The system was not actively used when this started.

    This system was originally set up with Samba Domain, which I had removed 2 weeks ago, trying to replace it by Samba. That substitution having failed I knew I had to rebuild my server from scratch but had been too busy doing that while I could do without Samba. The system has worked fine and not been updated during the last 2 weeks. This problem started quite suddenly.

    I'm out of clues as to what this is all about. I will rebuild my server but this is just nagging me.

  • Thanks again, but no success.
    There is a connected NIC, I can webconfig and FTP to the sytem. Indeed, there seems to be no way back once Samba Directory has been installed (and removed). So the only way is re-installing ClearOS which I already intended doing. I think it would be very helpful if the Samba initilizing process would give a clue as to why it's not processing, instead of sitting idle forever.

  • Nick,

    I'm ready for re-installing ClearOS but I would really like to understand what's happening. Maybe you could shed some light.

    This is what I've done:
    - removed Samba Directory after a Win10 upgrade made it inoperable
    - installed OpenLDAP and Samba
    - tried to configure Samba but it gets stuck in a loop (Connecting ....)
    - checked status of slapd and smb

    slapd seems OK: green dot. Status returns 2 messages that seem OK to me:
    Configuration directory '/etc/openldap/slapd.d' does not exist.
    Warning: Usage of a configuration file is obsolete!

    Running /bin/systemctl status smb.service
    ● smb.service - Samba SMB Daemon [dot is not green]
    Loaded: loaded (/usr/lib/systemd/system/smb.service; disabled; vendor preset: disabled)
    Active: inactive (dead)
    Docs: man:smbd(8)

    I have read some of your other posts indicating that the problem why Samba cannot initialize might be with the Directory service. As my slapd status seems OK there seems to be some remainer of Samba Directory causing the blocking. Re-installing the system would probably help. Or am I overlooking an obvious issue? (Wouldn't be for the first time :-))

    Kind regards, Roel