Matt Perry
Matt Perry
0 votes
I am running the latest version of CloudOS. I installed the PHP Engines app and am trying to develop a website I can serve up through CloudOS.

I have selected PHP Version 7.3.

When I go to Server>Web>Wordpress and click on access I get the error:
Your server is running PHP version 5.4.16 but WordPress 5.2.2 requires at least 5.6.20.

I am not sure where to start in debugging this problem or why I am getting this error when I have PHP 7.3 installed and selected.
Thursday, June 02 2022, 07:03 PM
Share this post:
Responses (1)
  • Accepted Answer

    Friday, June 03 2022, 08:20 AM - #Permalink
    0 votes
    Unfortunately Wordpress is a third party app and the developer never got it out of the beta phase, so there are issues with it and it is not integrated into the flexshare or web server mechanism so it does not get FTP access or use of PHP Engines.

    To fix the PHP version, it may work if you create a .phpenv file in the wordpress root folder, and in it just put "73" without the quotes. Otherwise, edit the wordpress file in /etc/httpd/conf.d (I am not sure what it is called but it should be obvious) and add the following lines in the <directory> section:
      <FilesMatch \.php$>
    SetHandler "proxy:fcgi://"
    The reply is currently minimized Show
Your Reply