Krz Kub
Krz Kub
0 votes
Dear All,

First of all - warm hello, as this is my first post here ;)

I have set up a pretty nice router based on ClearOS with mutli-WAN functionality at my office and now I was trying to do the similar at home.
The problem is that my Internet (fiber) required PPOE authentication and VLAN tagging.

I have read many threads on this forum and checked also other resources and still can’t make it work.
Here is what I think I have to do:
1. Configure WAN iface as external, PPOE (with user and pass and MTU)
2. Add VLAN (with ID) iface to WAN iface, also configure it as external, PPPOE
3. Configure LAN iface depending on own needs to be the gateway for LAN users

My problems are:
Ad 1. I don’t know which value of MTU I should put in PPPOE configuration. I have tried 1480, 1492. Does it have any influence on establishing the connection?
Ad 2. I can add VLAN to WAN iface, but I can’t change connection type to PPPOE. On ClearOs docs I found that this is a known bug, so it’s suggested 1st to configure it as DHCP and save. Then edit configuration and change to PPPOE, that should be available in this step. Unfortunately I still have only Static and DHCP options.

When I try to set it up as it should be via web-config, I have link=yes visible on WAN and LAN interfaces, but VLAN says link=no. There is also no IP obtained.
I have also tried to edit config files in /etc/sysconfig/network-scripts/ifcfg-* according to few threads found here, but no luck.

Is there a step-by-step tutorial, instruction showing how to solve this issue?
Or can you share print-screens and/or config files, pointing out what, where and in which order to change?

Thank you in advance,

Thursday, June 17 2021, 11:45 AM
Share this post:
Responses (1)
Your Reply