0 votes
b]Tonight[/b] (11/02/20-12/02/20) the following updated packages are being released:

  • None

* = the package is also being released to Business at the same time.

Packages available for testing

  • app-dns - another attempt to bind dnsmasq to interfaces only. It will be released next week if there are no adverse comments.
  • app-network - code merge complete. Seems to work for everything except external VLANs.

    • Now allows you to set up Wireless and Cellular interfaces. You will also need app-wireless to configure a NIC as an access point. Otherwise manual configuration is then needed for WiFi and Cellular devices.
    • I've tweaked it for kernel mode PPPoE (much faster and lower resoucres). For the moment we are not forcibly converting PPPoE interfaces over, but if you edit an interface it will switch to kernel mode.
    • Hides irrelevant interfaces from app-network-report such as docker0, veth* and ifb*.
    • Numerous other changes since last 2.6.0
    • Do not use the the update if you use VLAN's on external interfaces.

Unless detailed otherwise, packages available for testing can be installed with:
yum update --enablerepo=clearos-updates-testing {package-name}

Packages being worked on:

  • app-storage
  • app-sia - In theory it worked but does not. Fixes needed. I have an idea to get it working in Gateway mode but it is deathly slow.
  • app-openvpn to add three configuration parameters (client-to-client, "push block-outside-dns" and to force all traffic through the VPN). This is being worked on by an external contributor.
  • app-attack-detector to add a button beside each banned IP to you can unban it. This is being worked on by an external contributor.
  • kimchi 3.0 and wok 3.0. I can build wok and install and get it running with one python error. Kimchi will build but cannot install as I am missing a couple of dependencies. Kimchi is a great VM manager front end for KVM/libvirt. I have a feeling EPEL is going to end up being a brick wall. I've stopped on this one.
  • app-network - bug #41 should now be fixed. Two more bugs to go. Team Canada will be working on it.
  • nextcloud - upstream v18
  • Gateway Management update from AdamNetworks. I have access to the files and need to get them into the repos. More on this to come when I get them into the tesing repos.
Tuesday, February 11 2020, 09:40 PM
Share this post:
Responses (0)
  • There are no replies here yet.
Your Reply