0 votes
When I try to install this package, I get the following error:

Exception: [u'ERROR with transaction check vs depsolve:', ' is needed by snort-']

I have run an update check (both via the UI, and by running `yum update` as root).

Yum update reports repo clearos-updates is enabled.
Friday, January 26 2018, 06:31 PM
Share this post:
Responses (3)
  • Accepted Answer

    Saturday, January 27 2018, 11:26 AM - #Permalink
    0 votes
    Yum command worked. Nothing to update.
    Yum repolist gives:

    repo id repo name status
    clearos/7 ClearOS 7 - x86_64 - OS 75
    clearos-centos/x86_64 CentOS-7 - x86_64 - Base 7,367+8
    clearos-centos-sclo-rh/x86_64 CentOS-7 - x86_64 - CentOS Software Collections 6,54
    clearos-centos-updates/x86_64 CentOS-7 - x86_64 - Updates 1,197+16
    clearos-contribs/7 ClearOS 7 - x86_64 - Contribs 12
    clearos-epel/7/x86_64 EPEL 7 - x86_64 19,789+
    clearos-fast-updates/x86_64 ClearOS 7 - x86_64 - Fast Updates
    clearos-infra/7 ClearOS 7 - x86_64 - Infrastructure 1
    clearos-updates/7 ClearOS 7 - x86_64 - Updates 41
    download.mono-project.com_repo_centos7_ added from: 1,17
    private-clearcenter-dyndns ClearCenter Dynamic DNS
    repolist: 37,387

    However, when I attempted to install before, clearos-centos and clearos-centos-updates weren't enabled. I only enabled them on the advice of the Software Repositories app I installed yesterday. They were not enabled out of the box.

    I have just tried to install again,and it has worked. I suspect the install requires one or both of those repositories to be enabled.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 26 2018, 09:18 PM - #Permalink
    0 votes
    Can you try running a:
    yum clean all && yum update
    If it does not work, please give the output and also give the output to:
    yum repolist

    [edit for typo]
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 26 2018, 07:11 PM - #Permalink
    0 votes

    I haven't a clue what that error message is about, but I tested with Virtualbox and Intrusion detection / prevention installs fine on ClearOS Community. So the problem is your server. Maybe some else can help you further.
    The reply is currently minimized Show
Your Reply