0 votes

I'm using ClearOS 6 (free) and I've been having issues with the users/groups for quite some time due to LDAP problems. The error was similar to "unable to connect to LDAP" until i decided to update the system yesterday hoping this will fix the issue. Now the error is "No such object" and i can't even open the users page. I searched the forums and apparently this is some issue with LDAP and most people suggested restoring config backup. Unfortunately my last backup is from 2013 and it's not compatible with the current system.

I went ahead and started troubleshooting LDAP. and looks like the server is there, and is running. I started the openLDAP from console and tried to open the users page, then i can see error (32) in the console. Looks like error (32) means missing object, but i am not sure what exactly is missing and how do i get it back ?

I opened the 2013 backup and extracted the .ldif file from there. I also installed php ldap admin and connected without problems to the server. Then tried to import the .ldif file i got from the backup, but apparently all possible items it contains are already there.

Looks like the slapd service is running fine, it is accessible since i can open it via the default username and password provided, but can someone please send me an ldif file that has all the default values so i can import it in my system ? It can be found in the system configuration backup - var\clearos\openldap\snapshot.ldif

Thanks in advance!
In Users
Thursday, October 29 2015, 10:34 AM
Share this post:

Accepted Answer

Thursday, October 29 2015, 12:19 PM - #Permalink
0 votes
I just fixed it myself, if anyone else have this issue, here is how to fix it:

Make clearn installation of ClearOS (same version) on virtual machine, copy /var/lib/ldap/ from the virtual machine to yor server, restart slapd and you're done. Just make sure to make backup of that folder in case you need it.
The reply is currently minimized Show
Responses (0)
  • There are no replies here yet.
Your Reply