My Community Dashboard

  • Replacing COS7 system drive - won't boot

    Over the past week, logwatch has shown a kernel error. When I look back in the log I see it started a few weeks back. One day an error, then nothing for weeks. In the past week had 2 errors so time replace the drive.

    After many attempts, I can't get the replaced hard drive to boot. I believe it is missing a link but not sure how to diagnose. Any suggestions appreciated.

    Here is a summary of my attempted fixes ...

    Here is an example of the kernel errors.

    I installed smartmontools and ran it. The system disk is getting some errors. Decision time to replace the hard drive.

    Normally I'd do a fresh install but have added a bunch of customizations that I didn't document. So I thought it would be easier to just clone the drive???
    Sure enough there were posts in the forum recommending Clonezilla.
    The clonezilla failed the first time. I figured that must be due to the media errors that the kernel error mentioned. So I tried it again with the --recover and fsck options. Second time was successful.

    Then I replaced the drive in the server and rebooted. :-(

    I ended up seeing the grub menu and selecting the image but then dropping to dracut and getting "Entering emergency mode. Exit the shell to continue. Type 'journalctl" to view system logs. You might want to save "/run/initramfs/rdsosreport.txt" to a usb stick after mounting them and attach it to a bug report."

    Completely embarrassed as I couldn't figure out how to get the USB stick mounted to copy the file to add here. No /mnt and no ability to add a /mnt.

    Rebooted using ClearOS installer to try the recovery. The recovery got through to the grub menu and when selecting recovery it dropped to the dracut, Same happened when I selected any of the other kernel images.

    I tried to find the volumes to make sure they are there:

    All there.
    xfs_repair the lvm images but clearos-root appears to be missing the "superblock"?

    Now stuck.

    Put old drive back. Boots up and back working but not fixed. :-( Help.