Profile Details

Toggle Sidebar
Recent updates
  • Nick Howitt wrote:

    Odd. Kernel mode massively reduces the resources which is why it can manage such high speeds. Can you check your /etc/sysconfig/network-scripts/ifcfg-ppp0 has the line:If it does not, either your edit to Iface.php has not worked or you need to edit the interface in IP Settings and save it so it regenerates the file.

    It does contain that line :)

  • Which log is showing the errors. You may need to ignore them. The important thing is does it connect? The firewall rule will do nothing and is only needed for kernel mode, but it does not matter having it there when not in kernel mode.

    When in kernel mode, the MTU setting is meaningless so the firewall rule becomes very important.

  • Nick Howitt wrote:

    Unfortunately you are at the limit of my knowledge and I don't have any set up to test with. If a connection is made but unstable, it suggests a parameter mis-match somewhere which means sniffing PPPoE packets which I know nothing about, and I would not know how to tweak the connection either. Perhaps you could try googling.

    Ah, sorry! I think that you might have misunderstood me :)

    The connection is now stable. It works across all of the machines in my LAN.

    The quirks are:
    - If I run SpeedTest through the ClearOS WebGUI then that brings the connection down
    - It uses a lot of resources

    But as long as I don't touch the SpeedTest button in IP Settings part of ClearOS WebGUI then I'm fine :)

    Thank you for your time and all your help :)

  • After enabling the kernel mode the connection is possible, however not stable.

    After enabling the firewall rule the connection is not possible :(

    The log I mentioned previously was system log

  • Ok, So I have taken it step by step:

    remove config from eno1 - All good
    add VLAN on eno1 with VLAN ID: 35 and External/DHCP - All good
    Change VLAN (eno1.35) to PPPoE with correct login/pass and MTU - errors start to accumulate



  • So to sum this up:

    eno1 where the connection is placed should NOT be set up (button ADD available in the GUI)
    VLAN ID35 should be created on eno1

    VLAN should be set up as PPOE, is that correct?

    Apologies, it's always hard for me to think at the end of the week :)

  • It does not seem to be able to get IP address:

  • Thank you for the answer,

    So my steps should be as follow:
    On the external interface create VLAN with corrrect ID, set it as DHCP and external
    Then go back to the interface and change it to PPOE?

    I want to focus on getting the connection first :)))

  • External connection PPOE with VLAN ID

    Hello everyone!

    Recently I have got a new ISP hooked up to my apartment.

    I do have a HP Proliant MicroServer GEN8 with 2x10gbe intel x520 NIC and newest version of ClearOS Community version.

    At the moment my config is like this:
    1gbps ISP -> ISP ONT -> ISP Router -> ClearOS external
    500mbps ISP -> ISP Modem -> ClearOS external
    LTE ISP -> RJ45 Modem -> ClearOS external

    All is connected to my network with 1 port of the 10gbe intel card set up as internal with all of the gateway functions (dhcp, port forwarding, nat etc.) and multi-wan.

    However... I would like to eliminate the use of ISP Router in the first case, so I would like to go -> 1gbps ISP -> ISP ONT -> ClearOS external

    The problem is that this provider requires both usage of PPOE AND broadcast of VLAN ID.

    I have searched the forums wide and found several posts pertaining to this problem (e.g. solution with creating PPOE external connection and VLAN external, then modifying the conf file for one to use the other) however the solutions provided there did not work for me.

    Is there any other way I could do this setup properly without the use of ISP Router for 1gbps connection? I am afraid that ISP router in this case might be a huge limiter when it comes to the amount of packets routed.

    Would love some insight, thanks!