Profile Details

Toggle Sidebar
Recent updates
  • I'm back. I'm still working on my ISP to unblock incoming port 25. I may be making some headway with this finally.

    I also have a quick question on how I need my settings to be.

    under System -> Settings -> Mail Settings I have
    Mail Domain:
    Mail Hostname:

    I'm not exactly sure what these are and if the should be or or if they are fine as is.

  • When I do nmap I get the port being open. Must be because I'm on the network at home or something. I'll talk to my ISP again and see if I can get something figured out. Unfortunately comcast is my only option where I am at unless I want very slow DSL or Sat internet. Hoping that we get some competition in the area soon. I'll update this post again later when I can get the stuff sorted with my ISP.

    Thanks for your help.

  • Tony, Nick,

    Thanks for the great help. I do have a dynamic IP. My DNS is through clear. I don't use TurboSMTP for sending. I have just set up the relay through my ISP's SMTP server as per this document.

    I used the port 587 and STARTTLS section of that document in order to set up my outbound SMTP to run through

    I went to my Clearcenter DNS configuration. I made an MX record
    priority: 10

    I in my webconfig for the server I went to
    System -> Settings -> Mail Settings
    Mail Domain:
    Mail Hostname: (this was

  • Nick Howitt wrote:

    Try talking to your ISP about port 25. Some nasty ones will only allow it with a business line.

    The other hack attempts are the usual hack attempts. One of the joys or running a public facing server. The only reason for you to leave port 465 or port 587 open is if you want to send mails from your e-mail client via your server when you are external to your LAN

    I was able to talk to my ISP to open up incoming port 25! But I'm still not getting any mail that I can see. Here is the nmap showing the port open, but I'm still getting rejection messages from gmail and protonmail.

  • So if they are blocking incoming port 25 I am out of luck on hosting a mail server?

    Is there cause for concern on the other messages?

  • Update:

    I am able to send an email from to But when I try from google or protonmail it does not show up.

    I have checked my firewall and I have the following ports open.
    80, 443, 993, 995, 25, 587, 465, 81, 143, 110

  • Sending Mail Works Fine, but I Cannot Receive

    I've enabled my IMAP and POP3 along with SMTP. I usually have issues with getting mail to send due to my ISP blocking outgoing port 25, but I have gotten my SMTP relay setup properly with my ISP.

    My issue is that when I send an email to my server I don't get it. I've tried sending from and to the same email address on my clearOS system and that won't go. I have also tried sending from gmail and protonmail.

    Here is part of the error message I get from proton mail.

    Here is the error from Google

    I'm sure it is a setting in a config file that I messed up when I was going through this process.

    Every 15 seconds I am getting a connection attempt from I don't think it is google trying to send email to me. I get the same sequence each time it seems.

    I also am getting some other attempts from I don't think they are getting in either, but it sure is annoying.

  • Nathan
    Nathan replied to a discussion, Lag spikes through gateway

    So I'm not sure, but I think that was two commands...anyways, here are the outputs from them.

    # ifconfig |grep '^\S' -A 1
    eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet netmask broadcast
    enp8s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet netmask broadcast
    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
    inet netmask

    # cat /etc/clearos/network.conf
    # Network mode

    # Network interface roles

    # Domain and Internet Hostname

    # Extra LANS

    # ISP Maximum Speeds

  • Nathan
    Nathan replied to a discussion, Lag spikes through gateway

    I think this is solved but I'll report back in a few days. BIOS was up to date. I swapped the connections so my WAN connection is on the INTEL NIC and my LAN is on the other.

    I am seeing some other strange behavior I think.

    From my computer on the LAN I can ping and log into my cable modem just by typing in its IP address even though my computer is showing it to be on the LAN subnet and not the cable modem subnet.

    I do not have my cable modem in bridge mode.

    my computer is 10.10.10.x

    clear gateway
    WAN: 10.0.0.x

    cable modem is

    if I type in my address bar it goes to the cable modem config. I can also ping that IP address with windows command line.

    Not sure exactly what is happening here, but it seems fishy.

  • Nathan
    Nathan replied to a discussion, Lag spikes through gateway

    I was thinking about swapping them. My Intel is LAN. and Realtek is WAN. I'll try swapping them and report back. I recently did a BIOS update when it was my windows system, but I'll check to see if there is an update.