Forums

Resolved
0 votes
During 4 months, my ClearOS 7.1 installation was not updated. Now when I just run yum update I get this as following.
Also using update from WebConfig web-based interface, it says that I'm up-to-date. Of course I'm not.

Any help will be welcome!


[root@0dc00215 ~]# sudo yum update
Loaded plugins: clearcenter-marketplace, fastestmirror
ClearCenter Marketplace: fetching repositories...
http://ftp.nluug.nl/os/Linux/distr/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirror1-frankfurt.clearos.com/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://clearos.mirrors.ovh.net/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirror1-amsterdam.clearos.com/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://clearos.bhs.mirrors.ovh.net/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirror1-orem.clearos.com/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirror1-london.clearos.com/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirror1-singapore.clearos.com/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://mirror2.timburgess.net/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
http://www.mirrorservice.org/sites/clearfoundation.com/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.


One of the configured repositories failed (ClearOS 7 - x86_64 - OS),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).

3. Disable the repository, so yum won't use it by default. Yum will then
just ignore the repository until you permanently enable it again or use
--enablerepo for temporary usage:

yum-config-manager --disable clearos

4. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice
compromise:

yum-config-manager --save --setopt=clearos.skip_if_unavailable=true

failure: repodata/repomd.xml from clearos: [Errno 256] No more mirrors to try.
http://ftp.nluug.nl/os/Linux/distr/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
http://mirror1-frankfurt.clearos.com/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
http://clearos.mirrors.ovh.net/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
http://mirror1-amsterdam.clearos.com/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
http://clearos.bhs.mirrors.ovh.net/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
http://mirror1-orem.clearos.com/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
http://mirror1-london.clearos.com/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
http://mirror1-singapore.clearos.com/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
http://mirror2.timburgess.net/clearos/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
http://www.mirrorservice.org/sites/clearfoundation.com/testing/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found


My clearos.repo in /etc/yum.repos.d/ is as following:


[clearos]
name=ClearOS $releasever - $basearch - OS
#baseurl=http://mirror.clearos.com/clearos/testing/$releasever/os/$basearch/
mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-testing-os-$releasever
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-$releasever

[clearos-updates]
name=ClearOS $releasever - $basearch - Updates
#baseurl=http://mirror.clearos.com/clearos/testing/$releasever/updates/$basearch/
mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-testing-updates-$releasever
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-$releasever

[clearos-updates-testing]
name=ClearOS $releasever - $basearch - Updates (Testing)
#baseurl=http://mirror.clearos.com/clearos/testing/$releasever/updates-testing/$basearch/
mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-testing-updates-testing-$releasever
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-Testing-$releasever

[clearos-infra]
name=ClearOS $releasever - $basearch - Infrastructure
#baseurl=http://mirror.clearos.com/clearos/testing/$releasever/infra/$basearch/
mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-testing-infra-$releasever
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-$releasever

[clearos-infra-testing]
name=ClearOS $releasever - $basearch - Infrastructure (Testing)
#baseurl=http://mirror.clearos.com/clearos/testing/$releasever/infra-testing/$basearch/
mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-testing-infra-testing-$releasever
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-Testing-$releasever

[clearos-contribs]
name=ClearOS $releasever - $basearch - Contribs
#baseurl=http://mirror.clearos.com/clearos/testing/$releasever/contribs/$basearch/
mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-testing-contribs-$releasever
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-$releasever

[clearos-contribs-testing]
name=ClearOS $releasever - $basearch - Contribs (Testing)
#baseurl=http://mirror.clearos.com/clearos/testing/$releasever/contribs-testing/$basearch/
mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-testing-contribs-testing-$releasever
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-Testing-$releasever

Tuesday, May 03 2016, 09:37 PM
Share this post:
Responses (23)
  • Accepted Answer

    Monday, May 09 2016, 09:23 PM - #Permalink
    Resolved
    0 votes
    Good news!
    Based on your tips, I ran the following command excluding the packages in conflict.

    yum --exclude samba*,libldb*,libsmbclient,libwbclient,pyldb* update


    So, I updated everything except the excluded packages.

    Thank you all for your support, Nick and Tony. I really appreciated that.

    Now I will wait for samba package release for the next updates.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, May 07 2016, 02:10 PM - #Permalink
    Resolved
    0 votes
    Thank you, Tony!
    I'll try to update using your yum command with that exclude packages.
    Our CleaOs installation isn't in production yet, it's so closed, so I'll rest during the weekend and I'll resume at the next monday.

    Best weekend to all of you and thank you all for your support!
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, May 07 2016, 10:26 AM - #Permalink
    Resolved
    0 votes
    Nick, granted. The OP is free to limit which repositories he wishes to access, and would expect him to do so. My example gives an indication of what is required to ignore the samba upgrade on my system.

    In fact when I run the example for my system I get no "No packages marked for update". Remove the excludes and get a slew of samba packages and "Protected multilib versions: libldb-1.1.20-1.el7_2.2.i686 != libldb-1.1.25-1.el7_2.x86_64" as a final line.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, May 07 2016, 09:20 AM - #Permalink
    Resolved
    0 votes
    That will also open you up to the centos* unverified, and the testing repos. I'm not convinced that is a good idea unless you are prepared for the fallout.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, May 07 2016, 01:39 AM - #Permalink
    Resolved
    0 votes
    Dany - I was up-to-date just before the flawed samba packages were released to no real problem for me to pause my updates. I also have quite a number of i686 packages installed to support a 32-bit application so I get the multilib problem at times when the i686 and x86_64 updates are not released simultaneously.

    In my case to exclude samba I would require (that is one long line, and watch for split words. In my case the forum software has split "libsmbclient" between two lines)

    yum --enablerepo=* update -x samba* -x libwbclient -x libreplace-samba4.so -x libldb* -x libsmbclient -x pytalloc -x pyldb -x libtalloc
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 06 2016, 09:29 PM - #Permalink
    Resolved
    0 votes
    Nick, I will go crazy,

    yum update --exclude=*.i686,libldb


    Results in:


    --> Finished Dependency Resolution
    Error: Package: pyldb-1.1.25-1.el7_2.x86_64 (clearos-centos-updates)
    Requires: libldb(x86-64) = 1.1.25-1.el7_2
    Installed: libldb-1.1.20-1.el7_2.2.x86_64 (@clearos)
    libldb(x86-64) = 1.1.20-1.el7_2.2
    Error: Package: pyldb-1.1.25-1.el7_2.x86_64 (clearos-centos-updates)
    Requires: libldb.so.1(LDB_1.1.22)(64bit)



    # rpm -q --whatrequires pyldb
    samba-python-4.2.3-12.v7.x86_64


    I agree with you I don't see libldb 1.1.25 anywhere too.

    FYI, my current repo list, Am I missing something here.


    # rpm -q --whatrequires pyldb
    samba-python-4.2.3-12.v7.x86_64
    [root@0dc00215 ~]# yum repolist
    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    Loading mirror speeds from cached hostfile
    * clearos: mirror1-orem.clearos.com
    * clearos-centos: mirror.nbtelecom.com.br
    * clearos-centos-fasttrack: mirror.nbtelecom.com.br
    * clearos-centos-updates: mirror.nbtelecom.com.br
    * clearos-contribs: mirror1-orem.clearos.com
    * clearos-fast-updates: download1.clearsdn.com
    * clearos-infra: mirror1-orem.clearos.com
    * clearos-updates: mirror1-orem.clearos.com
    * private-clearcenter-dyndns: download3.clearsdn.com:80
    repo id repo name status
    clearos/7 ClearOS 7 - x86_64 - OS 718
    clearos-centos/7/x86_64 CentOS-7 - Base 8,927+80
    clearos-centos-fasttrack/7/x86_64 CentOS-7 - fasttrack 0
    clearos-centos-updates/7/x86_64 CentOS-7 - Updates 1,230+175
    clearos-contribs/7 ClearOS 7 - x86_64 - Contribs 72
    clearos-fast-updates/7/x86_64 ClearOS 7 - x86_64 - Fast Updates 43
    clearos-infra/7 ClearOS 7 - x86_64 - Infrastructure 17
    clearos-updates/7 ClearOS 7 - x86_64 - Updates 383
    private-clearcenter-dyndns ClearCenter Dynamic DNS 2
    repolist: 11,392
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 06 2016, 07:46 PM - #Permalink
    Resolved
    0 votes
    I think the samba-libs package is OK because it seems to require only the older libldb. I suspect it is the libldb itself so try:
    yum update --exclude=*.i686,libldb
    What I find odd is that I don't see libldb 1.1.25 in clearos-centos-updates.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 06 2016, 06:56 PM - #Permalink
    Resolved
    0 votes
    Nick, unfortunately your updated command
    yum update --exclude=*.i686


    result in:


    --> Finished Dependency Resolution
    Error: Package: samba-libs-4.2.3-12.v7.x86_64 (@clearos-updates)
    Requires: libldb = 1.1.20
    Removing: libldb-1.1.20-1.el7_2.2.x86_64 (@clearos)
    libldb = 1.1.20-1.el7_2.2
    Updated By: libldb-1.1.25-1.el7_2.x86_64 (clearos-centos-updates)
    libldb = 1.1.25-1.el7_2
    Available: libldb-1.1.20-1.el7.x86_64 (clearos-centos)
    libldb = 1.1.20-1.el7
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest


    Maybe it's because it's the Samba package that is creating the conflict. Do not you think?
    How do I exclude all Samba from the update?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 06 2016, 05:51 PM - #Permalink
    Resolved
    0 votes
    Try my updated command.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 06 2016, 03:44 PM - #Permalink
    Resolved
    0 votes
    Tony, thank you for your reply.
    You are right, it's Samba!


    [root@0dc00215 ~]# rpm -q --whatrequires libldb
    samba-libs-4.2.3-12.v7.x86_64


    So, are you advising to not upgrading anything until the present hold on the Samba upgrade is finalized and tested?

    But I do not understand as I'm not doing a upgrade, I would like to just *update* my current 7.1 installation. I have a couple of hundred packages to upgrade. When I tried to do the update, my bad luck, I did it just during the DNS problem and I got all those 404 errors. Apparently I had repositories pointing to those testing repo due the failure.

    Oh, gosh! All I wanted was to run yum clean all / yum update and maintain the system up-to-date and clean.

    Is there any way to update everything else except the Samba package?

    Tony, thank you again for your time. I really appreciated that.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 06 2016, 05:46 AM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    That happened for a while in the past in 6.x. Try:
    yum update --exclude=i686
    That was a typo. It should have been:
    yum update --exclude=*.i686
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 06 2016, 01:32 AM - #Permalink
    Resolved
    0 votes
    Do you have any i686 rpms installed? "rpm -qa | grep i686"

    I can reproduce this multilib error, but when I look at :-

    [root@sandra ~]# rpm -q --whatrequires libldb
    samba-libs-4.2.3-12.v7.x86_64
    [root@sandra ~]#

    I am not upgrading anything until the present hold on the samba upgrade is finalized and tested....
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, May 05 2016, 09:54 PM - #Permalink
    Resolved
    0 votes
    I would to like to post some more information.
    The package that is in conflict is libldb.


    yum list all libldb



    Installed Packages
    libldb.x86_64 1.1.20-1.el7_2.2 @clearos

    Available Packages
    libldb.i686 1.1.25-1.el7_2 clearos-centos-updates
    libldb.x86_64 1.1.25-1.el7_2 clearos-centos-updates


    So I tried to install both packages (i686 and x86_64) to synchronize the versions.

    yum install libldb.x86_64 libldb.i686



    At the end, I got "Multilib version problems" error for the following packages:


    Protected multilib versions: libldb-1.1.20-1.el7_2.2.i686 != libldb-1.1.25-1.el7_2.x86_64


    He looks like it needs the version 1.1.20..i686, but this package does not exist in the repo.

    If I try to upgrade instead update, I got the same.

    Should not this package version is stored in the repo?
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, May 05 2016, 05:57 PM - #Permalink
    Resolved
    0 votes
    I'm not sure how to get rid of this one. Anyone?

    You can try updating the other packages one by one, but it won't resolve the dependency error.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, May 05 2016, 03:08 PM - #Permalink
    Resolved
    0 votes
    FYI,
    libldb-1.1.20-1.el7_2.2.i686 is available, but not installed.

    If I try to update libldb-1.1.17-2.el7.x86_64, so I go the Protected multilib versions error.

    I can't figure out what I would to do to fix it!
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, May 05 2016, 02:55 PM - #Permalink
    Resolved
    0 votes
    Nick, thank you again for your support!

    Unfortunately,
     yum update --exclude=i686
    doen't work, the error still ocurrs:



    Error: Multilib version problems found. This often means that the root
    cause is something else and multilib version checking is just
    pointing out that there is a problem.
    [...]

    Protected multilib versions: libldb-1.1.20-1.el7_2.2.i686 != libldb-1.1.25-1.el7_2.x86_64


    Have you another clue?
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, May 05 2016, 06:23 AM - #Permalink
    Resolved
    0 votes
    That happened for a while in the past in 6.x. Try:
    yum update --exclude=i686
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, May 04 2016, 09:19 PM - #Permalink
    Resolved
    0 votes
    I enabled clearos-centos repo too.
    It seems that the dependencies were corrected at least so far.

    The error now is so weird:


    Error: Multilib version problems found. This often means that the root
    cause is something else and multilib version checking is just
    pointing out that there is a problem. Eg.:

    1. You have an upgrade for libldb which is missing some
    dependency that another package requires. Yum is trying to
    solve this by installing an older version of libldb of the
    different architecture. If you exclude the bad architecture
    yum will tell you what the root cause is (which package
    requires what). You can try redoing the upgrade with
    --exclude libldb.otherarch ... this should give you an error
    message showing the root cause of the problem.

    2. You have multiple architectures of libldb installed, but
    yum can only see an upgrade for one of those architectures.
    If you don't want/need both architectures anymore then you
    can remove the one with the missing update and everything
    will work.

    3. You have duplicate versions of libldb installed already.
    You can use "yum check" to get yum show these errors.

    ...you can also use --setopt=protected_multilib=false to remove
    this checking, however this is almost never the correct thing to
    do as something else is very likely to go wrong (often causing
    much more problems).

    Protected multilib versions: libldb-1.1.20-1.el7_2.2.i686 != libldb-1.1.25-1.el7_2.x86_6


    Any clue?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, May 04 2016, 08:47 PM - #Permalink
    Resolved
    0 votes
    clearos-centos is also disabled. If you need one you should enable both.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, May 04 2016, 08:43 PM - #Permalink
    Resolved
    0 votes
    Bingo! I enabled
    clearos-centos-updates
    repo, it was disabled. I got some package dependencies yet, but less than last
    yum update
    . Any clue?

    Last, but not least, could I apply

    --> Finished Dependency Resolution
    Error: Package: 1:cups-client-1.6.3-17.el7_1.1.x86_64 (@clearos-centos-updates)
    Requires: cups-libs(x86-64) = 1:1.6.3-17.el7_1.1
    Removing: 1:cups-libs-1.6.3-17.el7_1.1.x86_64 (@clearos-centos-updates)
    cups-libs(x86-64) = 1:1.6.3-17.el7_1.1
    Updated By: 1:cups-libs-1.6.3-22.el7.x86_64 (clearos)
    cups-libs(x86-64) = 1:1.6.3-22.el7
    Error: Package: 1:cups-1.6.3-17.el7_1.1.x86_64 (@clearos-centos-updates)
    Requires: cups-libs(x86-64) = 1:1.6.3-17.el7_1.1
    Removing: 1:cups-libs-1.6.3-17.el7_1.1.x86_64 (@clearos-centos-updates)
    cups-libs(x86-64) = 1:1.6.3-17.el7_1.1
    Updated By: 1:cups-libs-1.6.3-22.el7.x86_64 (clearos)
    cups-libs(x86-64) = 1:1.6.3-22.el7
    Error: Package: rpcbind-0.2.0-33.el7_2.x86_64 (clearos-centos-updates)
    Requires: libtirpc.so.1()(64bit)



    Here we are the current
    yum repolist
    :


    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    Loading mirror speeds from cached hostfile
    * clearos: ftp.nluug.nl
    * clearos-centos-updates: centos.xpg.com.br
    * clearos-contribs: ftp.nluug.nl
    * clearos-fast-updates: download3.clearsdn.com
    * clearos-infra: ftp.nluug.nl
    * clearos-updates: ftp.nluug.nl
    * private-clearcenter-dyndns: download4.clearsdn.com:80
    repo id repo name status
    clearos/7 ClearOS 7 - x86_64 - OS 718
    clearos-centos-updates/7/x86_64 CentOS-7 - Updates 1,230+175
    clearos-contribs/7 ClearOS 7 - x86_64 - Contribs 72
    clearos-fast-updates/7/x86_64 ClearOS 7 - x86_64 - Fast Updates 43
    clearos-infra/7 ClearOS 7 - x86_64 - Infrastructure 17
    clearos-updates/7 ClearOS 7 - x86_64 - Updates 383
    private-clearcenter-dyndns ClearCenter Dynamic DNS 2
    repolist: 2,465


    Nick, thank you very much for your support!
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, May 04 2016, 06:07 PM - #Permalink
    Resolved
    0 votes
    Can you check your repos:
    yum repolist
    If clearos-centos and clearos-centos-updates are disabled you may need to enable them again if you already have packages installed from them.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, May 04 2016, 04:24 PM - #Permalink
    Resolved
    0 votes
    As I said in previous post I'm in trouble with package dependencies now after I applied some fix to the repo list.
    The "avahi-glib conflicts with avahi-0.6.31-15.el7_2.1.x86_64" warning seems to be the bad guy.

    Here we are the dump list from yum as following:


    Error: Package: 1:cups-client-1.6.3-17.el7_1.1.x86_64 (@clearos-centos-updates)
    Requires: cups-libs(x86-64) = 1:1.6.3-17.el7_1.1
    Removing: 1:cups-libs-1.6.3-17.el7_1.1.x86_64 (@clearos-centos-updates)
    cups-libs(x86-64) = 1:1.6.3-17.el7_1.1
    Updated By: 1:cups-libs-1.6.3-22.el7.x86_64 (clearos)
    cups-libs(x86-64) = 1:1.6.3-22.el7
    Error: Package: tdb-tools-1.3.0-1.el7.x86_64 (@clearos-addons)
    Requires: libtdb = 1.3.0-1.el7
    Removing: libtdb-1.3.0-1.el7.x86_64 (@clearos)
    libtdb = 1.3.0-1.el7
    Updated By: libtdb-1.3.6-2.el7.x86_64 (clearos)
    libtdb = 1.3.6-2.el7
    Error: avahi-glib conflicts with avahi-0.6.31-15.el7_2.1.x86_64
    Error: Package: 1:mariadb-5.5.44-1.el7_1.x86_64 (@clearos-centos-updates)
    Requires: mariadb-libs(x86-64) = 1:5.5.44-1.el7_1
    Removing: 1:mariadb-libs-5.5.44-1.el7_1.x86_64 (@clearos)
    mariadb-libs(x86-64) = 1:5.5.44-1.el7_1
    Updated By: 1:mariadb-libs-5.5.44-2.el7.centos.x86_64 (clearos)
    mariadb-libs(x86-64) = 1:5.5.44-2.el7.centos
    Error: Package: 1:mariadb-server-5.5.44-1.el7_1.x86_64 (@clearos-centos-updates)
    Requires: mariadb-libs(x86-64) = 1:5.5.44-1.el7_1
    Removing: 1:mariadb-libs-5.5.44-1.el7_1.x86_64 (@clearos)
    mariadb-libs(x86-64) = 1:5.5.44-1.el7_1
    Updated By: 1:mariadb-libs-5.5.44-2.el7.centos.x86_64 (clearos)
    mariadb-libs(x86-64) = 1:5.5.44-2.el7.centos
    Error: Package: avahi-glib-0.6.31-14.el7.x86_64 (@clearos-addons)
    Requires: avahi-libs = 0.6.31-14.el7
    Removing: avahi-libs-0.6.31-14.el7.x86_64 (@anaconda/7.1beta2)
    avahi-libs = 0.6.31-14.el7
    Updated By: avahi-libs-0.6.31-15.el7_2.1.x86_64 (clearos)
    avahi-libs = 0.6.31-15.el7_2.1
    Error: Package: 1:cups-1.6.3-17.el7_1.1.x86_64 (@clearos-centos-updates)
    Requires: cups-libs(x86-64) = 1:1.6.3-17.el7_1.1
    Removing: 1:cups-libs-1.6.3-17.el7_1.1.x86_64 (@clearos-centos-updates)
    cups-libs(x86-64) = 1:1.6.3-17.el7_1.1
    Updated By: 1:cups-libs-1.6.3-22.el7.x86_64 (clearos)
    cups-libs(x86-64) = 1:1.6.3-22.el7


    Any help will be welcome!
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, May 04 2016, 03:51 PM - #Permalink
    Resolved
    0 votes
    I saw the notes about a certain DNS failure in last April. Some week ago I tried to update my server and the update was broked with 404 error. I think that was during that failure.
    Checking the /etc/yum.repos.d/ directory there was a clearos.repo.rpmnew file there. So I backed up the original clearos.repo file and I copied the *.rpmnew as clearos.repo.
    Voil√°, the repositories are back. But I don't know if they are the correct ones. But all seems to be Ok now, though I have some broken dependencies!

    Here my new clearos.repo as following:


    [clearos]
    name=ClearOS $releasever - $basearch - OS
    #baseurl=http://mirror.clearos.com/clearos/$releasever/os/$basearch/
    mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-current-os-$releasever
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-$releasever

    [clearos-updates]
    name=ClearOS $releasever - $basearch - Updates
    #baseurl=http://mirror.clearos.com/clearos/$releasever/updates/$basearch/
    mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-current-updates-$releasever
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-$releasever

    [clearos-updates-testing]
    name=ClearOS $releasever - $basearch - Updates (Testing)
    #baseurl=http://mirror.clearos.com/clearos/$releasever/updates-testing/$basearch/
    mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-current-updates-testing-$releasever
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-Testing-$releasever

    [clearos-infra]
    name=ClearOS $releasever - $basearch - Infrastructure
    #baseurl=http://mirror.clearos.com/clearos/$releasever/infra/$basearch/
    mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-current-infra-$releasever
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-$releasever

    [clearos-infra-testing]
    name=ClearOS $releasever - $basearch - Infrastructure (Testing)
    #baseurl=http://mirror.clearos.com/clearos/$releasever/infra-testing/$basearch/
    mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-current-infra-testing-$releasever
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-Testing-$releasever

    [clearos-contribs]
    name=ClearOS $releasever - $basearch - Contribs
    #baseurl=http://mirror.clearos.com/clearos/$releasever/contribs/$basearch/
    mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-current-contribs-$releasever
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-$releasever

    [clearos-contribs-testing]
    name=ClearOS $releasever - $basearch - Contribs (Testing)
    #baseurl=http://mirror.clearos.com/clearos/$releasever/contribs-testing/$basearch/
    mirrorlist=http://mirrorlist.clearos.com/clearos/mirrorlist/clearos-current-contribs-testing-$releasever
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS-Testing-$releasever
    The reply is currently minimized Show
Your Reply