Forums

Resolved
0 votes
I installed Kimchi with:

yum install app-kimchi


[root@columbia ~]# rpm -qa | grep kimchi
app-kimchi-core-1.1.8-1.v7.noarch
app-kimchi-1.1.8-1.v7.noarch
kimchi-2.5.0-0.v7.noarch


The problem I can't start app-kimchi. The server also boots with app-kimchi in a stop state.

I checked if libvirtd:

[root@columbia ~]# systemctl status libvirtd
● libvirtd.service - Virtualization daemon
Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2020-01-31 13:51:21 CET; 10min ago
Docs: man:libvirtd(8)
https://libvirt.org
Main PID: 1682 (libvirtd)
Tasks: 19 (limit: 32768)
CGroup: /system.slice/libvirtd.service
├─1682 /usr/sbin/libvirtd
├─2375 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/libexec/l...
└─2376 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/libexec/l...

Jan 31 13:51:21 columbia.lionux.lan dnsmasq[2366]: listening on virbr0(#4): 192.168.122.1
Jan 31 13:51:21 columbia.lionux.lan dnsmasq[2375]: started, version 2.76 cachesize 150
Jan 31 13:51:21 columbia.lionux.lan dnsmasq[2375]: compile time options: IPv6 GNU-getopt DBus no-i18n IDN DHCP DHCPv6 no-Lu...notify
Jan 31 13:51:21 columbia.lionux.lan dnsmasq-dhcp[2375]: DHCP, IP range 192.168.122.2 -- 192.168.122.254, lease time 1h
Jan 31 13:51:21 columbia.lionux.lan dnsmasq-dhcp[2375]: DHCP, sockets bound exclusively to interface virbr0
Jan 31 13:51:21 columbia.lionux.lan dnsmasq[2375]: reading /etc/resolv.conf
Jan 31 13:51:21 columbia.lionux.lan dnsmasq[2375]: using nameserver 127.0.0.1#53
Jan 31 13:51:21 columbia.lionux.lan dnsmasq[2375]: read /etc/hosts - 2 addresses
Jan 31 13:51:21 columbia.lionux.lan dnsmasq[2375]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 addresses
Jan 31 13:51:21 columbia.lionux.lan dnsmasq-dhcp[2375]: read /var/lib/libvirt/dnsmasq/default.hostsfile
Hint: Some lines were ellipsized, use -l to show in full.


..and it is. Not sure why Kimchi doesn't want to start.
Friday, January 31 2020, 01:03 PM
Share this post:
Responses (8)
  • Accepted Answer

    Friday, January 31 2020, 06:34 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    re the app-dns installation. Are you saying that you installed it before the first-run wizard? If so, what errors was it giving? I am wondering if it has something to do with having no trusted interfaces when first installed. This is something I would like to debug if at all possible. Is your server in standalone or gateway mode?

    [edit]
    I forgot to add, now you've run the wizard, can you please reinstall the app-dns update. It has a feature you need or you will need to do a manual configuration.
    [/edit]


    No, the wizard was executed before I installed the updated app-dns. I try again less see what happens!


    Update: Haven't the slightest idea why it triggered the wizard the first time after rebooting the server. User error? The only way to find out is to do a complete re-install of ClearOS.

    Anyway, it's updated now.

    Jan 31 13:31:34 Updated: 1:app-dns-core-2.7.4-1.v7.noarch
    Jan 31 13:31:35 Updated: 1:app-dns-2.7.4-1.v7.noarch
    Jan 31 13:38:43 Erased: 1:app-dns-2.7.4-1.v7.noarch
    Jan 31 13:38:43 Erased: 1:app-dns-core-2.7.4-1.v7.noarch
    Jan 31 13:39:20 Installed: 1:app-dns-core-2.7.2-1.v7.noarch
    Jan 31 13:39:20 Installed: 1:app-dns-2.7.2-1.v7.noarch
    Jan 31 19:36:14 Updated: 1:app-dns-core-2.7.4-1.v7.noarch
    Jan 31 19:36:14 Updated: 1:app-dns-2.7.4-1.v7.noarch


    You see my first try in the log..
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 31 2020, 06:30 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    That is really not helping. When kimchi was installed, it should have installed wok and a bunch of other rpm's. A lot of them would be libvirt rpms but what were they? Can you post all the rpm's installed at the same time as app-kimchi from your yum log.


    Yes, your right it installed a lot of dependencies. The installed rpms list:

    Jan 31 13:23:05 Installed: yajl-2.0.4-4.el7.x86_64
    Jan 31 13:23:05 Installed: glusterfs-libs-3.12.2-47.2.el7.x86_64
    Jan 31 13:23:05 Installed: 2:libogg-1.3.0-7.el7.x86_64
    Jan 31 13:23:05 Installed: gperftools-libs-2.6.1-1.el7.x86_64
    Jan 31 13:23:05 Installed: iscsi-initiator-utils-iscsiuio-6.2.0.874-11.el7.x86_64
    Jan 31 13:23:05 Installed: iscsi-initiator-utils-6.2.0.874-11.el7.x86_64
    Jan 31 13:23:06 Installed: libtirpc-0.2.4-0.16.el7.x86_64
    Jan 31 13:23:06 Installed: libevent-2.0.21-4.el7.x86_64
    Jan 31 13:23:06 Installed: fuse-libs-2.9.2-11.el7.x86_64
    Jan 31 13:23:06 Installed: bzip2-1.0.6-13.el7.x86_64
    Jan 31 13:23:06 Installed: boost-system-1.53.0-27.el7.x86_64
    Jan 31 13:23:06 Installed: boost-thread-1.53.0-27.el7.x86_64
    Jan 31 13:23:06 Installed: unbound-libs-1.6.6-1.el7.x86_64
    Jan 31 13:23:07 Installed: rpcbind-0.2.0-48.el7.x86_64
    Jan 31 13:23:07 Installed: perl-hivex-1.3.10-6.9.el7.x86_64
    Jan 31 13:23:07 Installed: hivex-1.3.10-6.9.el7.x86_64
    Jan 31 13:23:07 Installed: python2-pyasn1-0.1.9-7.el7.noarch
    Jan 31 13:23:07 Installed: libcollection-0.7.0-32.el7.x86_64
    Jan 31 13:23:07 Installed: python-six-1.9.0-2.el7.noarch
    Jan 31 13:23:07 Installed: augeas-libs-1.4.0-9.el7.x86_64
    Jan 31 13:23:07 Installed: libiscsi-1.9.0-7.el7.x86_64
    Jan 31 13:23:07 Installed: rdma-core-22.1-3.el7.x86_64
    Jan 31 13:23:07 Installed: libibverbs-22.1-3.el7.x86_64
    Jan 31 13:23:07 Installed: lzop-1.03-10.el7.x86_64
    Jan 31 13:23:07 Installed: boost-random-1.53.0-27.el7.x86_64
    Jan 31 13:23:07 Installed: libref_array-0.1.5-32.el7.x86_64
    Jan 31 13:23:07 Installed: boost-iostreams-1.53.0-27.el7.x86_64
    Jan 31 13:23:08 Installed: 1:librados2-10.2.5-4.el7.x86_64
    Jan 31 13:23:08 Installed: 1:librbd1-10.2.5-4.el7.x86_64
    Jan 31 13:23:08 Installed: libbasicobjects-0.1.1-32.el7.x86_64
    Jan 31 13:23:08 Installed: python-ipaddress-1.0.16-2.el7.noarch
    Jan 31 13:23:08 Installed: python-lxml-3.2.1-4.el7.x86_64
    Jan 31 13:23:09 Installed: python2-psutil-2.2.1-5.el7.x86_64
    Jan 31 13:23:09 Installed: 10:qemu-kvm-common-1.5.3-167.el7_7.1.x86_64
    Jan 31 13:23:09 Installed: librdmacm-22.1-3.el7.x86_64
    Jan 31 13:23:09 Installed: netcf-libs-0.2.8-4.el7.x86_64
    Jan 31 13:23:09 Installed: gnutls-dane-3.3.29-9.el7_6.x86_64
    Jan 31 13:23:09 Installed: libverto-libevent-0.2.5-4.el7.x86_64
    Jan 31 13:23:09 Installed: 1:libvorbis-1.3.3-8.el7.1.x86_64
    Jan 31 13:23:09 Installed: celt051-0.5.1.3-8.el7.x86_64
    Jan 31 13:23:09 Installed: flac-libs-1.3.0-5.el7_1.x86_64
    Jan 31 13:23:10 Installed: glusterfs-3.12.2-47.2.el7.x86_64
    Jan 31 13:23:10 Installed: glusterfs-client-xlators-3.12.2-47.2.el7.x86_64
    Jan 31 13:23:10 Installed: glusterfs-api-3.12.2-47.2.el7.x86_64
    Jan 31 13:23:10 Installed: 10:qemu-img-1.5.3-167.el7_7.1.x86_64
    Jan 31 13:23:10 Installed: glusterfs-cli-3.12.2-47.2.el7.x86_64
    Jan 31 13:23:10 Installed: libcgroup-0.41-21.el7.x86_64
    Jan 31 13:23:10 Installed: 1:quota-nls-4.01-19.el7.noarch
    Jan 31 13:23:10 Installed: libvirt-bash-completion-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:10 Installed: 2:nmap-ncat-6.40-19.el7.x86_64
    Jan 31 13:23:10 Installed: autogen-libopts-5.18-5.el7.x86_64
    Jan 31 13:23:11 Installed: gnutls-utils-3.3.29-9.el7_6.x86_64
    Jan 31 13:23:11 Installed: 1:nginx-filesystem-1.12.2-2.el7.noarch
    Jan 31 13:23:11 Installed: libwebp-0.3.0-7.el7.x86_64
    Jan 31 13:23:11 Installed: python-pillow-2.0.0-19.gitd1c6db8.el7.x86_64
    Jan 31 13:23:11 Installed: perl-libintl-1.20-12.el7.x86_64
    Jan 31 13:23:11 Installed: scrub-2.5.2-7.el7.x86_64
    Jan 31 13:23:11 Installed: libasyncns-0.8-7.el7.x86_64
    Jan 31 13:23:11 Installed: opus-1.0.2-6.el7.x86_64
    Jan 31 13:23:12 Installed: spice-server-0.14.0-7.el7.x86_64
    Jan 31 13:23:12 Installed: python2-futures-3.1.1-5.el7.noarch
    Jan 31 13:23:12 Installed: sos-3.7-10.el7.centos.noarch
    Jan 31 13:23:12 Installed: keyutils-1.5.8-3.el7.x86_64
    Jan 31 13:23:12 Installed: python-enum34-1.0.4-1.el7.noarch
    Jan 31 13:23:12 Installed: lsof-4.87-6.el7.x86_64
    Jan 31 13:23:12 Installed: fuse-2.9.2-11.el7.x86_64
    Jan 31 13:23:12 Installed: libusal-1.1.11-25.el7.x86_64
    Jan 31 13:23:12 Installed: genisoimage-1.1.11-25.el7.x86_64
    Jan 31 13:23:12 Installed: 1:pyparted-3.9-15.el7.x86_64
    Jan 31 13:23:12 Installed: gdisk-0.8.10-3.el7.x86_64
    Jan 31 13:23:12 Installed: tcp_wrappers-7.6-77.el7.x86_64
    Jan 31 13:23:13 Installed: 1:quota-4.01-19.el7.x86_64
    Jan 31 13:23:13 Installed: ipxe-roms-qemu-20180825-2.git133f4c.el7.noarch
    Jan 31 13:23:13 Installed: PyPAM-0.5.0-19.el7.x86_64
    Jan 31 13:23:13 Installed: cyrus-sasl-gssapi-2.1.26-23.el7.x86_64
    Jan 31 13:23:13 Installed: libvirt-libs-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:14 Installed: libvirt-client-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:14 Installed: perl-Sys-Virt-4.5.0-2.el7.x86_64
    Jan 31 13:23:14 Installed: libvirt-python-4.5.0-1.el7.x86_64
    Jan 31 13:23:14 Installed: mtools-4.0.18-5.el7.x86_64
    Jan 31 13:23:14 Installed: syslinux-4.05-15.el7.x86_64
    Jan 31 13:23:14 Installed: syslinux-extlinux-4.05-15.el7.x86_64
    Jan 31 13:23:14 Installed: usbredir-0.7.1-3.el7.x86_64
    Jan 31 13:23:14 Installed: 1:sgabios-bin-0.20110622svn-4.el7.noarch
    Jan 31 13:23:14 Installed: python-ipaddr-2.1.11-2.el7.noarch
    Jan 31 13:23:14 Installed: python-ethtool-0.8-8.el7.x86_64
    Jan 31 13:23:15 Installed: osinfo-db-20190319-2.el7.noarch
    Jan 31 13:23:15 Installed: spice-html5-0.1.7-1.el7.noarch
    Jan 31 13:23:15 Installed: libnfsidmap-0.25-19.el7.x86_64
    Jan 31 13:23:15 Installed: supermin5-5.1.19-1.el7.x86_64
    Jan 31 13:23:15 Installed: attr-2.4.46-13.el7.x86_64
    Jan 31 13:23:15 Installed: python-ldap-2.4.15-2.el7.x86_64
    Jan 31 13:23:15 Installed: gd-2.0.35-26.el7.x86_64
    Jan 31 13:23:15 Installed: 1:nginx-mod-http-image-filter-1.12.2-2.el7.x86_64
    Jan 31 13:23:15 Installed: 1:nginx-mod-http-geoip-1.12.2-2.el7.x86_64
    Jan 31 13:23:15 Installed: 1:nginx-mod-http-xslt-filter-1.12.2-2.el7.x86_64
    Jan 31 13:23:15 Installed: 1:nginx-mod-stream-1.12.2-2.el7.x86_64
    Jan 31 13:23:15 Installed: 1:nginx-mod-http-perl-1.12.2-2.el7.x86_64
    Jan 31 13:23:16 Installed: 1:nginx-1.12.2-2.el7.x86_64
    Jan 31 13:23:16 Installed: 1:nginx-mod-mail-1.12.2-2.el7.x86_64
    Jan 31 13:23:16 Installed: 1:nginx-all-modules-1.12.2-2.el7.noarch
    Jan 31 13:23:16 Installed: 1:app-nginx-core-2.3.0-1.v7.noarch
    Jan 31 13:23:16 Installed: gsm-1.0.13-11.el7.x86_64
    Jan 31 13:23:16 Installed: libsndfile-1.0.25-10.el7.x86_64
    Jan 31 13:23:16 Installed: pulseaudio-libs-10.0-5.el7.x86_64
    Jan 31 13:23:16 Installed: seabios-bin-1.11.0-2.el7.noarch
    Jan 31 13:23:16 Installed: python-ply-3.4-11.el7.noarch
    Jan 31 13:23:16 Installed: python-pycparser-2.14-1.el7.noarch
    Jan 31 13:23:17 Installed: python-cffi-1.6.0-5.el7.x86_64
    Jan 31 13:23:17 Installed: m2crypto-0.21.1-17.el7.x86_64
    Jan 31 13:23:17 Installed: radvd-2.17-3.el7.x86_64
    Jan 31 13:23:17 Installed: squashfs-tools-4.3-0.21.gitaae0aff4.el7.x86_64
    Jan 31 13:23:17 Installed: python-idna-2.4-1.el7.noarch
    Jan 31 13:23:17 Installed: hexedit-1.2.13-5.el7.x86_64
    Jan 31 13:23:17 Installed: python2-markdown-2.4.1-4.el7.noarch
    Jan 31 13:23:17 Installed: python-cherrypy-3.2.2-4.el7.noarch
    Jan 31 13:23:17 Installed: libpath_utils-0.2.1-32.el7.x86_64
    Jan 31 13:23:17 Installed: libini_config-1.3.1-32.el7.x86_64
    Jan 31 13:23:18 Installed: gssproxy-0.7.0-26.el7.x86_64
    Jan 31 13:23:18 Installed: 1:nfs-utils-1.3.0-0.65.el7.x86_64
    Jan 31 13:23:18 Installed: python-repoze-lru-0.4-3.el7.noarch
    Jan 31 13:23:18 Installed: python2-jsonschema-2.5.1-4.el7.noarch
    Jan 31 13:23:18 Installed: python-backports-1.0-8.el7.x86_64
    Jan 31 13:23:18 Installed: python-backports-ssl_match_hostname-3.5.0.1-1.el7.noarch
    Jan 31 13:23:18 Installed: python-setuptools-0.9.8-7.el7.noarch
    Jan 31 13:23:18 Installed: python-websockify-0.6.0-2.el7.noarch
    Jan 31 13:23:18 Installed: novnc-0.5.1-2.el7.noarch
    Jan 31 13:23:19 Installed: python2-cryptography-1.7.2-2.el7.x86_64
    Jan 31 13:23:19 Installed: python-paramiko-2.1.1-9.el7.noarch
    Jan 31 13:23:19 Installed: python-pygments-1.4-10.el7.noarch
    Jan 31 13:23:19 Installed: python2-cheetah-2.4.4-5.el7.x86_64
    Jan 31 13:23:21 Installed: wok-2.5.0-1.v7.noarch
    Jan 31 13:23:21 Installed: libconfig-1.4.9-5.el7.x86_64
    Jan 31 13:23:21 Installed: numad-0.5-18.20150602git.el7.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-storage-core-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-network-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-nwfilter-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-config-network-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-qemu-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-secret-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-interface-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-nodedev-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-config-nwfilter-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-lxc-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-storage-mpath-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-storage-scsi-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-storage-iscsi-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-storage-disk-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-storage-logical-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-storage-gluster-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-storage-rbd-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-daemon-driver-storage-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: libvirt-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:22 Installed: seavgabios-bin-1.11.0-2.el7.noarch
    Jan 31 13:23:23 Installed: 10:qemu-kvm-1.5.3-167.el7_7.1.x86_64
    Jan 31 13:23:23 Installed: libvirt-daemon-kvm-4.5.0-23.el7_7.3.x86_64
    Jan 31 13:23:23 Installed: 1:libguestfs-1.40.2-5.el7_7.2.x86_64
    Jan 31 13:23:23 Installed: 1:perl-Sys-Guestfs-1.40.2-5.el7_7.2.x86_64
    Jan 31 13:23:24 Installed: 1:libguestfs-tools-c-1.40.2-5.el7_7.2.x86_64
    Jan 31 13:23:24 Installed: 1:libguestfs-tools-1.40.2-5.el7_7.2.noarch
    Jan 31 13:23:24 Installed: 1:python-libguestfs-1.40.2-5.el7_7.2.x86_64
    Jan 31 13:23:24 Installed: python-magic-5.11-35.el7.noarch
    Jan 31 13:23:25 Installed: kimchi-2.5.0-0.v7.noarch
    Jan 31 13:23:25 Installed: 1:app-kimchi-core-1.1.8-1.v7.noarch
    Jan 31 13:23:25 Installed: 1:app-kimchi-1.1.8-1.v7.noarch
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 31 2020, 05:31 PM - #Permalink
    Resolved
    0 votes
    I do see an install error:
    sed: can't read /etc/dnsmasq.d/*: No such file or directory
    But it did all the right things. I'll see if I can correct the issue.

    [edit]
    I was being an idiot. Most of the output removed ....
    The one line error is being corrected in app-dns-2.7.5.
    [edit]
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 31 2020, 05:17 PM - #Permalink
    Resolved
    0 votes
    re the app-dns installation. Are you saying that you installed it before the first-run wizard? If so, what errors was it giving? I am wondering if it has something to do with having no trusted interfaces when first installed. This is something I would like to debug if at all possible. Is your server in standalone or gateway mode?

    [edit]
    I forgot to add, now you've run the wizard, can you please reinstall the app-dns update. It has a feature you need or you will need to do a manual configuration.
    [/edit]
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 31 2020, 05:09 PM - #Permalink
    Resolved
    0 votes
    That is really not helping. When kimchi was installed, it should have installed wok and a bunch of other rpm's. A lot of them would be libvirt rpms but what were they? Can you post all the rpm's installed at the same time as app-kimchi from your yum log.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 31 2020, 03:24 PM - #Permalink
    Resolved
    0 votes
    This is a default install with only Kimchi. Fresh and new from ISO 7.7.

    I've seen that thread and I installed app-dns. After that I rebooted the server and ClearOS started with wizard and there were dns errors. So I removed the updated app-dns...
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 31 2020, 02:24 PM - #Permalink
    Resolved
    0 votes
    link

    [edit]
    - although your problem may be different. What else was installed at the same time as kimchi?
    [/edit]
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 31 2020, 01:25 PM - #Permalink
    Resolved
    0 votes
    Found this on wikisuite but it is not helping.
    The reply is currently minimized Show
Your Reply