0 votes
Hello, I have a ClearOS server that I use to manage users and permissions for multiple PCs with Windows.
I have a flexshare called archive, with windows sharing, that a certain group of users can read and write into. I needed every other user to be able to only read from said directory, so I created a different flexshare, with read only, called history pointing to a symlink that pointed to the original archive directory.
Now this works. The archive users can read and write, and every other user can only read.
But after a couple of days non archive users stop being able to access the folder at all.
To fix this I go into the history flexshare, press edit on settings and press save without changing anything and it starts working again. All users can read from it again.
A few days later it happens again.
I wanna know if I'm doing something wrong or if there's and alternate method to accomplish this.
Friday, June 14 2019, 02:06 PM
Share this post:
Responses (1)
  • Accepted Answer

    Friday, June 14 2019, 04:43 PM - #Permalink
    1 votes
    There is a nightly cron job which resets flexshare ownership. You can disable it by changing FlexshareSecurityPermissions to "off" (or anything but "on"!). I am not in favour of this.

    My preference would be to pull your Read-Only flexshare definition in /etc/samba/flexshare.conf into a new file, /etc/samba/myshares.conf, then change the path to point to the proper share. Then in /etc/samba/smb.conf, add a line:
    include /etc/samba/myshares.conf
    just below the line:
    include = /etc/samba/flexshare.conf
    The restart windows networking. This pulls your read-only share outside the flexshare system and it will not mess things up. Also ClearOS will not overwrite any of your changes.

    If you wanted to make a share like this read/write then it adds complications of file ownerships.
    The reply is currently minimized Show
Your Reply